\
) "’ e-ISSN: 2319-8753 | p-ISSN: 2347-6710

International Journal of Innovative Research in
SCIENCE | ENGINEERING | TECHNOLOGY

INTERNATIONAL JUURNAI.
OF INNOVATIVE RESEARBH

IN SCIENCE | ENGINEERING | TECHNOLOGY

Volume 12, Issue 4, April 2023

‘ ‘INTERNATIONAL
STANDARD
.\ SERIAL Impact Factor: 8.423

NUMBER
INDIA

0 9940572 462 (O 6381907 438 = ijirset@gmail.com . WWW.ijirset.com



International Journal of Innovative Research in Science, Engineering and Technology (IJIRSET)

AR

IJIRSET | Volume 12, Issue 4, April 2023 ||

|e-ISSN: 2319-8753, p-ISSN: 2347-6710] www.ijirset.com | Impact Factor: 8.423| A Monthly Peer Reviewed & Referred Journal |

| DOI:10.15680/1JIRSET.2023.1204053 |

Green House Monitoring System Using IOT

Prof. Smita Kalmegh, Namrata Bhojane, Apeksha Bendarkar, Pooja Nimje, Swati Kalokar,
Kajal Gosavi, Mayuri Sapkal

Department of Electrical Engineering, P. R. Pote Patil College of Engineering & Research, Amravati,

Maharashtra, India

ABSTRACT: Greenhouse monitoring and Control System is the approach in which the rural areas farmers will be
benefitted by this Greenhouse environment. This project focuses on the Generic architecture and it can also be applied
for many other automation-based application. Direct supervision of human will be replaced. By referring the different
papers, we have proposed the system based on the limitations which is present in the monitoring and control system.
Greenhouse is where the plants are grown with the controlled manner. Nowadays, Greenhouse construction is in greater
demand due to the lack of land availability and urbanization. Growing crops will be reserved mainly by this proposed
Greenhouse project. From the location wireless, Greenhouse using IoT can be used to monitor and control many
Greenhouse buildings.
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I. INTRODUCTION

A Greenhouse, which is a exceptionally outlined homestead structure. This gives a more controllable environment to a
better crop security, transplantation, harvest generation and product seeding. As a part of this present-day period, for
developing yields, following to more space of area which has vigorously utilized for commercial ventures and housing
the area space is accessible. The cost-effective farming such as new blossoms, organic products and vegetables
generation is the utilization of Greenhouse development in many tropical nations. The conformity of ideal atmosphere
development conditions which is to attain to the high return at great quality, low natural burden and low cost is the
effectiveness of plant creation inside Greenhouse which depends fundamentally. Parameters like light, humidity,
temperature, soil moisture must be controlled ideally where the given certain criteria through water creation, warming,
ventilation and lighting are used to attain certain objectives. By persistent checking and controlling of these ecological
parameters which gives a significant data that is related to the individual impacts of the elements differently towards
acquiring the most extreme creation of harvest. The present remarkable difficulties of Greenhouse is to control.
Temperature changes quickly, In Greenhouse as a result, fluctuations relying upon sun powered radiation level,
moisture levels and outside temperatures. Poor natural product set and quality frequently bought by the high stickiness
and poor light intensity. Expanding the efficiency of labourers by empowering them for the more important
assignments, electrical expenses and heating fuel, empowering producers and directors to settle on better administration
choices and to invest more on the energy dealing with procedures can be decreased by practicing exact control over the
system. In this thesis, we have proposed a system which can read the parameters data from the environment which is
identified within the Greenhouse and will be controlled manually or by Android app which we have developed. In the
cloud data will be stored for future use. If any climate values fluctuate the precautionary measures will be taken by the
user. The relationship between reference estimations and sensor flags, breaking down the developments, the natural
variables which are uncovered and advancement of yields are explorated by strictly observing climate changing
conditions.
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Fig 1: Block Diagram

II. METHODOLOGY

A greenhouse monitoring system using NodeMCU can be built using the following methodology:

1. 1. Hardware requirements:

o NodeMCU (ESP8266) board

o Temperature and humidity sensor (DHT11 or DHT22)

o Light sensor (LDR)

o Soil moisture sensor

o Breadboard and jumper wires

2. 2. Set up the NodeMCU board:

o Connect the NodeMCU board to your computer using a USB cable.

o Download and install the Arduino IDE software.

o In the Arduino IDE, go to Tools > Board and select "NodeMCU 1.0 (ESP-12E Module)" as the board.

o Select the correct COM port under Tools > Port.

3. 3 . Install necessary libraries:

o Install the DHT sensor library and the Adafruit Unified Sensor library by going to Sketch > Include Library >
Manage Libraries.

o Install the PubSubClient library for MQTT communication.
4. 4. Connect the sensors to the NodeMCU board:

o Connect the DHT sensor to the NodeMCU board's 3V3, GND, and D4 pins.

o Connect the LDR to the NodeMCU board's 3V3, GND, and A0 pins.

o Connect the soil moisture sensor to the NodeMCU board's 3V3, GND, and Al pins.

5. 5. Write the code:

o Use the Arduino IDE to write the code for the greenhouse monitoring system. The code should read the values from
the sensors and publish them to an MQTT broker. It should also subscribe to commands from the broker to control
devices such as fans or lights.

o Connect to the Wi-Fi network using the SSID and password in the code.

6. 6. Test the system:

o Upload the code to the NodeMCU board and test the system.

o Use an MQTT client to subscribe to the topics and verify that the values are being published correctly.

o Send commands to the broker and verify that the devices are being controlled correctly.

7. 7. Deploy the system:

o Once the system has been tested, deploy it in the greenhouse and connect it to a power source.

o Ensure that the system is configured to automatically connect to the Wi-Fi network and reconnect if the connection is
lost.
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Overall, the methodology involves setting up the NodeMCU board, connecting the sensors, writing the code, testing the
system, andfinally deploying it in the greenhouse. By following these steps, you can build an effective greenhouse
monitoring system using NodeMCU.

III. MODELING AND ANALYSIS

i

Fig 2: Light sensor

A light sensor is a photoelectric device that converts light energy (photons) detected to electrical energy (electrons).

Fig 3: Temperature & Humidity sensor

The temperature and humidity readings obtained from the DHT11 sensor are not very accurate, but are suitable for
most hobbyist projects. If you need more accurate readings, you may want to consider using a higher-end sensor such
as the DHT?22 or the SHT31.

Fig 4: Moisture sensor

Soil moisture sensors are electronic devices that are commonly used to measure the water content of soil in real-time.
These sensors typically consist of two probes that are inserted into the soil, and they measure the electrical conductivity
of the soil to determine the water content.
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Fig 5. NodeMcu ESP8266

A greenhouse monitoring system using NodeMCU is a project that involves developing a system for monitoring the
environmental conditions inside a greenhouse using a NodeMCU board, sensors, and software.

WORKING MODEL

Fig 6: Greenhouse control system

This control unit collects all the details regarding the plant growth. Consisting of moisture, temperature and light sensor
with a mini water tank attached for supplying sufficient amount of water to plants. The whole controlling system is
having a power supply of Sv. LED is present in the controlling unit for providing enough light for the plants and a mini
fan for controlling the temperature. Display concole shows the measured values of moisture and temperature. We have
created a cloud for storing all the details about the growth of plants. And have Developed an android application for
monitoring the greenhouse and controlling the environment inside the greenhouse.
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IV. RESULT
HUMIDITY & TEMPERATURE SOIL MOISTURE
CROP TAKEN
>50% <50%
[WET)] [DRY]
Idx LDR LED WATER WATER PUMP
[Ideal Threshold Value] PUMP
0 [OFF ] 1[ON] OFF ON
1[ON] 0 [OFF ]

From the above table, take the Ideal threshold value for any crop is found to be Idx(Humidity and Temperature) andfor
moisture it is 50%.

1. If the LDR is 0 means LDR is OFF then LED is 1 means LED is ON automatically. When LED is ON it is a day
time.

2. If the LDR is 1 means LDR is ON then LED is 0 means LED is OFF automatically.When LED is OFF it is a night
time.

3. If the moisture content is greater than 50%, then it sense by soil moisture sensor, then water pump will OFF
automatically.

4. If the moisture content is less than 50%, then it sense by soil moisture sensor, then water pump will ON
automatically.

V. CONCLUSION

This Greenhouse project is designed intelligently for the betterment of the crop growth. The system gives the high
efficiency plant growth, low cost and effective working. The user can control it manually and also using the Android
app which we have developed. Greenhouse is more effective than the plants grown normally. The Android app is used
to check the status inside the Greenhouse and can be handled it easily. The software and hardware working is so
smoothly done and can be used easily. The system design give the user to understand the working and very ease to use
it. The yield is so effective and the data can be stored in cloud for the future use.

REFERENCES

1. Yuthika Shekar, Ekta Dagur, Sourabh Mishra “Intelligent IoT Based Automated Irrigation System”, B. Tech
Graduate, Department of Information Technology, SRM University, Kattankaluthur Campus, Chennai-601302,

2. India,2017

3. Shirsath, PunamKamble, Rohini Mane, Ashwini Kolap, Prof.R.S. More “IoT Based Smart Greenhouse Automation
Using Arduino, 2017Gyusoo Kim and Seulgi Lee, “2014 Payment Research”, Bank of Korea, Vol. 2015, No. 1,
Jan. 2015.

4. Sridevi,Shreejith K, T.V.Ramachandra,”Comparative Analysis of Greenhouse”,2017.

5. Quan Minh Vu, "Automated Wireless Greenhouse Management System", Master of Engineering in Electronics
and Computer Systems, Massy University, Palmerston North, New Zealand, June 2011.

6. T. Saha, M.K.H Jewel, M.N. Mostakin, N.H. Bhuiyan, M.S.Ali and M.K.Rahman, ”C onstruction and
Development of an Automated Greenhouse System Using Arduino Uno”,Dept of Applied Physics, Electronics &
Communication Engineering, Islamic University, Kushtia,Bangladesh,2019.

7. "Greenhouse Automation with NodeMCU" by

(https://www.hackster.io/alexsosedkin/greenhouse-automation-with-nodemcu-0Oc40aa)

"Greenhouse Monitoring System" by Michael Heinzl

9. (https://www.hackster.io/michael-heinzl/greenhouse-monitoring-system-b 1c9bb)

Alexander Sosedkin

*®

IJIRSET©2023 | AnISO 9001:2008 Certified Journal | 3018


http://www.ijirset.com/
https://www.hackster.io/alexsosedkin/greenhouse-automation-with-nodemcu-0c40aa
https://www.hackster.io/michael-heinzl/greenhouse-monitoring-system-b1c9bb

INTERNATIONAL %3
INNO @ SPACE d srmmn
SIF Scientific Journal Impact Factor s sml’ 'a
fentific - ({*
sref mmm
cros
SC IR

Impact Factor: 8.423 l\ DIA

INTERNATIONAL JOURNAL
OF INNOVATIVE RESEARCH

IN SCIENCE | ENGINEERING | TECHNOLOGY

(5 9940 572 462 [@ 6381 907 438 () ijirset@gmail.com ;;ﬁ”"

Ww.ijirset.com



	ABSTRACT: Greenhouse monitoring and Control System is the approach in which the rural areas farmers will be benefitted by this Greenhouse environment. This project focuses on the Generic architecture and it can also be applied for many other automatio...
	I. INTRODUCTION
	II. METHODOLOGY
	III. MODELING AND ANALYSIS
	From the above table, take the Ideal threshold value for any crop  is found to be Idx(Humidity and Temperature) andfor moisture it is 50%.
	1. If the LDR is 0 means LDR is OFF then LED is 1 means LED is ON automatically. When LED is ON it is a day time.
	2. If  the LDR is 1 means LDR is ON then LED is 0 means LED is OFF automatically.When LED is OFF it is a night time.
	3. If the moisture content is greater than 50%, then  it sense by soil moisture sensor, then water pump will OFF automatically.
	4. If the moisture content is less than 50%, then  it sense by soil moisture sensor, then water pump will ON automatically.
	V. CONCLUSION
	REFERENCES


